GUI Concepts

In this task, you'll create this rod cap using 2D sketching tools, then sweep a solid from the 2D geometry and
add some fillets.
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1. Step 1: Get Ready to Sketch!

As you go through the steps, keep these things in mind:

» Ifyou get into trouble, you can always click Undo to go back to the previous step.

+  To exit a command, press the [Esclkey or hit the [XI Cancel button in the Selection List.

Also, don't forget to set the focus back to the ThinkDesign window after scrolling or clicking in this browser

window. You can do so:

* By clicking on the title bar of the ThinkDesign window OR....

* By clicking on a blank part of the ThinkDesign window.

Don't click in the Graphics area, especially when a command is active as you might end up picking a point!

Let's start by closing the History Tree and fitting the view to the window.

» Place the cursor on the vertical bar separating the History Tree from the Graphics Area. You'll see the cursor
change to .

* Drag the bar to the left to close the History Tree.

«  Click Fit View or hit the [F Jkey to fit the model to the current view.
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In the next step, we'll start drawing
2. Step 2: Create the shape

In this step, we'll use the existing construction lines to sketch the main shape of the rod cap.

Start the Polyline command to draw the profile of the rod cap.

*  Click the Polyline button on the Drafting toolbar OR..
+ Select Insert>Drafting ¥ Polylinefrom the pull down menu.

The Selection List -- located in the top left corner of the Graphics Area -- displays all the options needed to
complete the desired command. The default options for the Polyline command is Mode Line and Option Polar
(P). These are the options we'll use to start.
= /2 Polyling E_x-_;
P

Mode Line -

QOption Polar (P} -
[ Work Plane en Last Point

ThinkDesign displays @ Points, an arrow with a red background icon and orange text in the Selection List when
it is requesting input for a particular feature or command. It also displays command prompt in the lower right
hand corner of the main application window (see image below). It's important to keep an eye on the prompt as to
know what's happening. The Polyline command is prompting you to Enter the line start point in the command
prompt and showing a @ Points in the Selection list.

* Snap to the lower left intersection of the two dashed construction lines

You'll know you have the exact point when you see the X and the Intersecting Point tool tip.
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Intersecting Poirt

The first line is 0.375 long at an angle of 90° -- we'll use the Mini Dialogs to input those values. Since we have
two Mini Dialogs ( Length and Angle ) we need to determine which one is active to receive keyboard input. In
this case, we know it is the Length because the input area is orange.

«  Type 0.375 and hit the [TabJkey to set the length. Length0.375 in
= 72 Potyine [3€)

@ Points

Mode Ling -

QOption Polar (P} -

O Work Plane on Last Point

Length 0.25 in
!

Angle 15 deg

Hit the ey again to move the cursor to the Angle Minidialog

.

e Type 90.

Hit (T2t Jor to set the angle value. Angle90 deg

Remember that when you type values into Mini Dialogs that aren't activated (i.e. cursor isn't flashing), use the
number keys across the top of the keyboard. If you want to use the number pad instead, make sure Num Lock is
on. Otherwise you'll activate the dynamic viewing commands we learnt in the last task.
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@ Points

Mode Ling
Option Polar (P} -
O Work Plane on Last Point

Length 0.1in

Angle 65 deg

With both values specified, the line is drawn and you're on to the next one, a horizontal line with a length of
0.625.

*  With the Length box active, type 0.625 to set the distance of this line: Length0.625 in

« Hit the [Tt Jkey twice to switch to the other Mini Dialog -- the Angle box

*  Type 0 to set the angle of this line: HorizontalO deg

« Hit[ Ente Jo create the line.

@ Points

Mode Ling
Option Polar (P} -
O Work Plane on Last Point

Length 0.1in

Angle 65 deg

For the next segment we'll use a 3-Point Arc.

*  Choose 3-Point Arc option from the Mode drop down list.
= #¢ Potyine (3]

@ Points

I.|c|t|e

Optio Line
| 3-Point Arc

0 Wangent Ao o

The first point we'll enter is the endpoint.

» Set the length to 1. Lengthl
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» Set the angle to 0. HorizontalO deg

The second point we need is the middle point.

* Snap to the intersection of the centerline and the upper dashed construction line. Remember to look for the
'X' for the Intersecting Point.

“¢ Potvine ()

@ Points

Mode 3-Point Arc -

Option Polar (P} -
O Work Plans on Lazt Point

rsecﬁng Puaint

The next segment extends horizontally to the right vertical construction line. This time, we'll combine Mini Dia-
log input with a snap to get the point we need.
» Set the angle to 0 (horizontal) to lock the line orientation. Angle0 deg

* Snap to the point where the upper horizontal construction line and the right vertical construction line inter-
sect.

Intersecting Point

Lenath 0.625 in

Angle 0 deg

Continue down through the vertical line.

» Snap to the intersection of the lower horizontal construction line and the right vertical construction line.

Length 0.375in
'
'
| 1
'
'

We've typed in a lot of values up to this point; now let's try another input method: Set up the Dynamic Grid so

Intersecting Point

5
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the cursor will move in preset increments. The Grid Properties can be set from the Standard toolbar - Grid pull
down menu as in the image below or from the menu View > Grid ¥ Properties

o84
{88 Grid Off

| ﬁ Hidden Dynamic Grid
B static Grid

* Under Hidden Dynamic Grid.
+  Make sure ¥ Enable is checked.
* Uncheck Enable flexible step for now, until you get used to the dynamic grid.

» Set the Linear step: to 0.125.

¢ Close with OK.

Document Properties - Grid

Document Properties l

Grid Static grid
Type: m
Step: 0.5in ﬂ
Major line subdivisions: ’57:‘
Hidden dynamic grid
v Enable
™ Flexible step
Linear step: 0.125in ﬂ
Angular step: ’F:‘
Parametric step: 0.1 j

ok | cancdl | Defar |

Continue to the left with a horizontal line, angle 180 and length 0.875.

* Drag the cursor to the left until the length of the line is 0.875. Length0.875

* Drag the cursor up or down until the angle is 180. Horizontal180

* Pick the point where both values are correct.

- ]

Herizontal 180 deg

Time for another 3-Point Arc. Remember that we need the endpoint first, then the midpoint. For the endpoint,
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you can either type or drag the Mini Dialog values.

Select the 3-Point Arc option from the Mode drop-down list.
» Set the length to .5. Length0.5

* Set the angle to 180. Horizontal180

* Snap to the point (the little x ) on the centerline.

You'll know you have the right point when a small circle appears around it, and the point tool tip is visible.

- #4¢ Poine [ 3€)
@ Points

Mode 3-Foint Arc -

Optien Polar (P} -
[0 waork Plane on Last Point

Now let's close the shape.

* Move the cursor near the starting point.

* Pick the point at which the preview line turns red and the starting point is highlighted.

= 2 Polyine (3
@ Points

Mode Ling +

Option Polar (P} -
O Work Plane on Last Point

Length 0.8789 in /_TL
_____ X ____1_____
|

i
\ lIntersecting Pairt |
I
\

Closing the shape automatically ends the Polyline command, selecting all of the segments.
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We've covered lot of ground here. Let's move on to the next step and add some 2D fillets to the shape we've just
created.

3. Step 3: Refine the Shape

In this step, we'll add some 2D fillets to refine the shape of the rod cap as shown below.

[

We don't need the construction geometry any more, so let's turn off the Output Layers.

+ Click Format®Layersfrom the pull down menu.
» In the Show list, select Relevant Layers.
*  Uncheck the Vis box for Layer 10 and add a Description if you want.

* Click OK.

FEFTE
[ Inwertfiter  Filter: I—L]

C| Name ] On | Lock | Color | Line ..
W 0 ¢ & N

7]

)| x|
[~ Invertfiter  Filter: ’—L|

C| Name | On | Lodk | Calor | Line ..
¥ 0 P % N
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‘ < >

|
RIZETe = |

With the construction lines out of the way, let's fillet some corners.

+  Click Insert Fillet on the Drafting toolbar OR pick Insert¥>Drafting ¥ Filletfrom the pull down menu.
«  Type .125 and hit [TabJor [ Entes Jto set the fillet radius. Radius0.125

The Mini Dialog in the Insert Fillet command works just like Mini Dialogs in the Polyline command.

» Select the left vertical line near the top.

» Select the upper left horizontal line near the left side.

@ | Fitet ()
@ Curves
O Quadrant

Sequence Single -

TrimiExtend Curves Both -

Rad?u:‘%‘lr?%in

Repeat the procedure for the upper right corner.

* Pick the right vertical line, near the top.

*  Pick the upper right horizontal line, near the right end.
& § Fiet (€]

@ curves

O Guadrant

Sequence Single -

Trim/Extend Curves Both -

e [g/ :
F|‘.adius 0.25in ﬁﬁ= m

Now we'll add 0.25 fillets between the upper horizontal lines and the upper arc.

* Change the radius value to 0.25. Radius0.25
» Pick the upper arc, near the left end.
* Pick the upper left horizontal line, near the right end.

* Repeat for the right side of the arc.
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[

 Hit[Escjto end the command.

Adjusting the graphics. Now we want to make our model look a little better. If you've noticed, the curves in
our sketch don't look very smooth. We can adjust the graphics to smooth out our curves.

Make sure that nothing is selected and right click in the background (Graphics Area) and in the context
menu select Options/Properties

Select 4
Wiew L4
Part Data 4

Options/Properties...

A

Customize

In this dialog window, select Document Properties tab and select Tessellation branch. Make the Boundary toler-
ance and Surface tolerance equal to .001 then click OK.

Entity Properties - Tessellation
System Options | Document Properties  Entty Propates |
Generzl Tesseliation parameters
H-Hatch
Curve,/Suface ¥
Tesselation Fir
= Dimens
- Line and Amow v Custom
Em:' Surface tolerance: 001in
+ Ini
:_hlz'gure Boundarytolerance:  |001in
# Tolerance
T Suface scoinacy (2 [100 :I‘
- Symbol
= Ted
* Fort & Frame
Hign
+ Sheet Metal
Apply Changes
ok | cace | Detmr | ¢ sean |

Looking good! In the next step, we'll use these curves to create a solid.
4. Step 4: Sweep the Solid

It's time to make a solid from our new shape.

10
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First, we need to reselect all the curves that make up the profile of the rod cap. We'll use the Select Chain selec-
tion tool.

+  Click Edit®Select®Chainfrom the pull down menu and pick a curve OR right click on one of the curves
and hit Select > Chain from This in the context menu.

[ ChainfiomThis, ____|
&3
Modify Entities i Window
Enable Assodiativity q{ Chain
."_:@‘ Work Plane on Curve @ All
Xy Move/Copy

Insert
Formats L4
x Delete
Zoom Entities
% Hide Entities

Set Filter to 'Curves'

T Filter ...

-

View +

Info 4
q Search this Name

.I.@ Edit Properties
Select Properties from Entity
Set Properties as Current

Customize

With the curves selected, we'll sweep a solid with Linear Solid command.

+ Click the Linear Solid button in the drop down in the Solids toolbar OR select Insert?>Solid>Sweep™
Linear Solidfrom the pull down menu.

11
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- g Linear Solid (3] v (1)
@ Profie
[®- More Optionz

*  Grab the Handle (the red dot) and pull it to dynamically adjust the depth of the solid.

The green handle (green dot) decides whether or not it will be symmetric when it is double clicked.

= g Linear Soid () W7 (1)
@ Profie
&~ More Options

Set the depth to 0.5.

* Click on the input area of the Mini Dialog and type 0.5 OR drag the handle. Depth0.5.
«  Click the ¥ OK button in the Selection List OR right click and pick ¥ OK from the context menu.

Either method confirms the settings and creates the solid.

* Set the shading to Shaded View and Boundaries and have a look.

12
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We're almost done. In the last step, we'll add some 3D fillets to finish the part.
5. Step 5: Adding 3D Fillets

In this step, we'll finish the rod cap by adding fillets to two edges with Fillet Edges tool.

Let's add Fillet!

* Click and hold the right button of the mouse to rotate the model so that you can see its far face.

» Right click on the top front edge and select Insert Fillet>Edges from the context menu.

Select

%’ Redefine Feature
F‘% Show Driving Dimensions
.":Y.? Work Plane on Curve

Insert
Formats £

Edge Chamfer E\!
,f/ Parallel Line

Zoom Entities
View 3
Info 3
Q Search this Name
.l‘@ Edit Properties

Select Properties from Entity
Set Properties as Current

Customize

«  Type 0.06 and hit [TabJto set the fillet radius Radius0.06.

13
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* Pick the edge on the backside of the model to fillet that edge as well.
- @ EdeeFilet (3 ) LD
=)~ Group 1 Constant radius —
@ cdges(Radius=0.06in)
&~ Group Oiuns

[#- Group 2 Constant radius ~

[+ More Options

+ Right click and pick ¥ OK from the context menu OR click the ™ OK button in the Selection List to com-
plete the fillets.

i,
=3

To finish the job, click on the Hide Entities button in the Attributes toolbar to hide all the entities other than the
solid.

+  OR choose View¥Hide Entitiesfrom the pull down menu and click on the entities other than the solid.

6. Step 6: Creation of Base solids.
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Set the work plane on lower face of the solid by right clicking on the face and click on Work Plane Here.

Select L

(vorcpencriee ]
y Redefine Feature k

F‘% Show Driving Dimensions

Insert ¥
Zoom Entities

View 3
Info 3
Q~ Search this Mame

i Edit Properties
Select Properties from Entity
Set Properties as Current

Customize
Go to & Profile mode.
Insert Modify Format Tools thinkteam Window Help thinkreshz
<
Drafting Ml 3o
2 : 5
DA q Tangency
Solid 4 %. Parallelism
Datum 4 d. Crientation
Component 4 /. Collinearity
Point N ggoplanjit‘j_ .
[ . erpendicularity

Select the Parallel Line command.

* Select the edge as shown.
»  Keep the option Type to Copy length.

» Set the offset distance to 0.4.

Similarly draw another parallel line by selecting the bottom edge of same offset distance 0.4.
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Using the same command to create other 2 parallel lines selecting the vertical edges with zero offset value.

e Activate command Trim/Extend Curves.

» Select the left vertical and upper horizontal lines to extend.
o R

* Similarly extend four sides and make a rectangle as shown.

16
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e Activate Linear Protrusion command.
+ Select extension option as Depth.
* Set the Depth value to 0.125.

+  Click Ml OK.

. Linear Protrusion w w Lﬁ
@ Profie

= Extenszion Depth -

° Face

[#-- More Options

Let us store this view orientation in RAM memory so that you can recall it at a later stage. For this choose the
Remember command from the view -> modify menu bar item.
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& Redraw Al Shift+R & ‘ 0 = i
Q Previous r kz = K 5 X
& e R
v Work Plane w bl ".:L:Q}‘,E‘C
Absolute Reference System (World) Shift+w ;i
o NS E0
o Jas
(@), Zoom Entites
Smart Object Library " ~
%R endering Library @, Zoom on Point of Interest
1/Q Window & zoom "
=10 wi @ scae
% Hide Entities €, Pan
&M Unhide Entities [ Work Plane View
12\ Hide Inner Epfities &7 Set Direction
— »|  Step Actions 4
N Show Driving Dimensions [ set Targe
"\ Hide Driving Dimensions [l Reset Target
" Highlight Dimensions Ciri+H |4 Shrink
X Symbolc References £ Unshrink
@, Fit Texts to View &y Define Section View
Part Properties »
Recall g
Properties...

To check whether we could store the View using the new option, rotate the solid and switch to Wireframe

View.
‘mat Tools thinkteam Window Help

w. | R KX
peee ]

g Shaded View
8 Shaded View + Boundaries
4 @ Shaded View Boundaries + Hidden Lines

{7} Boundary View
Ea Boundary View + Hidden Lines

[} High Quality Shaded view
Ea High Quality Shaded View + Boundaries
@ High Quality Shaded View + Boundaries + Hidden Lines

Now select Recall to get the view orientation that was saved using the Remember command.
View Insert Modify Format Tools thinkteam Window Help

&= Redraw Al Shift4R | Jisn R
L o 2R FEX
= « BlOCC Oc
Absolute Reference System (World) shift+w | :
nd 10 I B®
[ € Pan/Zoom/Rotate
Orientation »
Dieplay ' % ZE:orn Enfities
ﬁ Smart Object Library )
T @& Zoom on Point of Interest
{5 Rendering Library @, zoom Windo
5 /0 Window | @ scale
£\ Hide Entities @, Pan
i Unhide Entities [T, Work Plane View
M\ Hide Inner Entities £7) Set Direction
mage »  Step Actions »
#\ Show Driving Dimensions [] et Target
. Hide Driving Dimensions Il Reset Target
/" Highlight Dimenisions Ctri+H | {E Shrink
X Symboic References £3 Unshrink
@, Fit Texts to View iy Define Section View
Part Properties 4

After having successfully used the new commands, let's create mirror solid and pattern of the simple holes in the
last step to finish this task.
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7. Step 7 . Simple holes and pattern feature.

Let's add simple holes to this base solid.
+ Activate Hole.

» Select the type to Cartesian.
e Set the values as shown.

«  Click L1 Apply.
5 @ e (X & (D
& Face ¥
= Type Cartesian -
o Origin
° Reference direction Ling -
@ Reference planar face
O For screw EEEER 02in

= Hole type: Simple i
I

Extension Thru all -
I

- More Options

*  Now click Origin in selection list.
* Using End Point Snap select the bottom corner point for the Origin.

«  Say VI OK.

19


http://thinkcare.think3.com/thinkcare/help2009t1/english/features/FWfile/T_FW_ft_01.htm
http://thinkcare.think3.com/thinkcare/help2006/english/snap/FWfile/T_FW_to_01_15.htm
http://thinkcare.think3.com/thinkcare/help2006/english/snap/FWfile/T_FW_to_01_15.htm
http://thinkcare.think3.com/thinkcare/help2006/english/snap/FWfile/T_FW_to_01_15.htm

GUI Concepts

5 @ e (X &) (D
@ Face
= Type Cartesian -
& origin
° Reference direction Ling -
@ Reference planar face
O For screw

= Hole type: Simple i
I

Extension Thru all -
I

- More Options

Model looks like this.

Now let's make a mirror of this solid to create the final part.

+ Start the Mirror Solid command.

» Select the base solid for the Base entity.

* Select Perpendicular to axis and through point for First Symmetry Plane option.
+ Select one of the edges as the axis line.

» Select the centre point of the half circle for the Point selection.
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= &l wirror Soid (3] W) (10
@ Base Entties
= First Symmetry Plane Perpendicular to axis & through point -
= @ Axis Line v
& origin
& Foint

Second Symmetry Plane None -

[®- More Optionz

+  Click M OK.

We need to create holes on the other side using the Pattern Solid command.

« Start Pattern Solid command.

» Set Type Linear.

» Select the Simple holes created as the Base Entities in the Selection List.
* Click on any of the horizontal edges of the base solid as indicated below.
» Set the 1st No. copies 2.

* Set the 1st Extension 1.45in.

. Hit MIOK.
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- o solid Pattern | 3€) V7 (L1

@ Base Entties

Placement: Fit

= Type: Linear -

& 1stDirection Line -
—

[# More Options

Now select the Linear protrusion profile from the history tree and choose Edit Profile from the context menu to
modify the base solid.

EI% RodCap.e3
= solid (4)

..... &% Feature Pattern (28)

----- ﬁ Feature Pattern (24)

..... A Mirror Solid (20)

..... u Through Hele [D=5.08] {19)

..... i) Through Hole [D=5.08] (14)

Linear Protrusion (3)

..... 0?";@(5} 44 Roll Back Here
A,

- @@ P ‘Unlink

? Delete Feature

Insert 4
Rename
b Unhide Entities

Search
Search this Name

Info »

.l'@ Edit Properties
Select Properties from Entity
Set Properties as Current

let's Insert Fillet to the two inner corners of the base solids.

*  Click on Insert Fillet on the Drafting toolbar .
*  Type 0.2 as the Fillet Radius.
» Select the edges as shown below.

* Double click on the screen to update the model.
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GUI Concepts

Hide dimension lines and profiles to give the model a better look.

Looking good! Congratulations.
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